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  5. When viewed in a different time zone, a whole day appointment appears to span an additional day

When viewed in a different time zone, a whole day appointment appears to span an additional day

Symptoms

When viewing a whole day appointment it can sometimes appear to span across two days

Cause

When a new appointment is created the start time is converted to UTC (Universal Time) by the WorkgroupShare client before being sent to the server during the client synchronization. The server sends and receives all time information for appointments in UTC to allow for clients in different time zones.

If this data is downloaded from the server to another client in the same time zone then the computers time zone offset is applied to the UTC time to convert the appointment back to the correct local time. In the case of a whole day appointment, an additional flag is set to indicate that the appointment spans the whole day (from midnight to midnight). For a client on the same time zone when the appointment is converted back to local time the appointment will still be whole day, from midnight to midnight.

If this data is downloaded instead to a client in a different time zone then when the computers time zone offset is applied to the UTC time in the data the appointment will be created as a whole day appointment spanning times other than midnight to midnight. This will cause the appointment to be created as a whole day appointment spanning an extra day. The position of the extra day (before or after the original) will depend on the direction of the time zone difference.

Resolution

We are aware that this can cause confusion and are considering alternative ways of displaying whole day appointments in different time zones.

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