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Setting the OfficeTalk mainRoot

Symptoms

The following undesirable effects may be seen if the OfficeTalk mainRoot is incorrectly set

  • The tip-of-the-day file cannot be found
  • Blank entries for counties in contact mode
  • The today mode browser reports ‘page not found’
  • Palm Conduit reports an invalid mainRoot

Cause

The mainRoot is a registry entry that contains a path to shared files on the OfficeTalk server computer. Occasionally the mainRoot may be incorrectly set and the above symptoms will occur when a client is unable to locate the necessary shared resources. This can occur, for instance, when connecting to the server over a VPN or when running the setup in a non-standard way.

Resolution

Manually set the mainRoot value in the registry as described below.

More Info

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

Detail

The mainRoot setting on any OfficeTalk installation can be set as follows:

In order to start the registry editor click Start, Run, type regedit and press enter.

Navigate to the following key:

HKEY_CURRENT_USERSoftwareSoftalkOfficeTalkOptions

Double-click on the mainRoot value

On the OfficeTalk ‘server’ computer, mainRoot should be set to be the OfficeTalk installation path, for example, C:Otalk. On the OfficeTalk client installations, mainRoot should be set to the parent folder of the path from which OfficeTalk setup was run. If, for example, OfficeTalk setup was run from \SERVEROTALKSETUP32 then the main root should be set to \SERVEROTALK. In principle, this path must point to the ‘OTALK’ folder on the OfficeTalk ‘server’ computer. This can be via a UNC path or mapped drive, but must be accessible.

If you are working over a VPN connection, or for some reason cannot resolved NetBIOS names, then this can be set to a local path. Set mainRoot to the local Program FilesOfficeTalk folder. Note that files that are accessed via the main root path will need to be copied from the server. Copy all of the *.dat files (such as Cntries.dat), ottips.txt and access.bin.

Note: The most common reason for the mainRoot being set incorrectly is when the client setup is run from a shared setup32 folder. OfficeTalk client setup should always be run from a shared otalk folder. OfficeTalk 4.5.1 and later will display a warning if the client setup is run from a shared setup32 folder. Older versions of OfficeTalk do not perform this check and so the mainRoot should be changed manually if setup has been run in this way.

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