On logon after upgrading I get the error ? User does not exist in this domain (55)?

  1. Home
  2. Knowledge Base
  3. GMS
  4. On logon after upgrading I get the error ? User does not exist in this domain (55)?

Question

I have just upgraded from V3 to V5 of NTMAIL, and when I login as the administrator (postmaster), and go to users, I get the error:

A script error has occurred – User does not exist in this domain (55)

Our users are getting/sending mail, and can login to the WWW interface and runs fine. But the administrator doesn’t see any users on the domain.

Answer

This implies that you either have a user listed in the UserAccessList that does not have any AccessRights assigned to them, or you have a user with AccessRights assigned but they does not appear in the UserAccessList.

The UserAccessList is a System Variable, and AccessRights is a User Variable. The easiest way to sort through this is to generate a copy of setup.txt from the Security > System Recovery page then using a text editor capable of performing searches make sure that both sets of variables match up. The UserAccessList will be near the beginning of the file under the heading SOFTWAREInternetShopperMailUsers: while
the AccessRights are listed under the individual users in each domain.

The AccessRights are listed under the individual users in each domain.

  1. Make a note of the users in the UserAccessList. They are sorted by domains, and domains are separated by a colon.
  2. Search through the file for the term “accessrights”. This should display all user accounts that have access rights other than default (which aren’t listed.)
  3. Compare the users with non-default access rights against the UserAccessList. They should match up. If they don’t, please send a copy of your setup.txt file to support for analysis, along with a reference to this FAQ article.

Keywords:access postmaster script error config

Was this article helpful?

Related Articles