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Mail downloaded from my ISP is not delivered to the correct local user

Symptoms

Mail downloaded from the ISP is delivered to the wrong local account or is delivered to the default account that receives mail for unknown recipients.

Cause

When a message is received by an ISP or domain host and placed into a multiple user POP3 mailbox, the message should be marked as being for a specific recipient. The header field used for this purpose varies between different ISP’s. The most common is the ‘Received’ header field that may look something like:

Received: from [123.123.123.123] (helo=domain1.com)
by mailserver.domain2 with smtp
id 123-456-789
for John@domain.com; Fri, 01 Aug 2003 08:00:00 +0100

Or, an ISP may use the ‘Delivered-To’ header field that may look something like:

Delivered-To: John@domain.com

If WorkgroupMail is configured to check the wrong header then the message may be delivered incorrectly.

Resolution

Each ISP object in WorkgroupMail is configured with a prioritised list of the most common header fields used for mail delivery. Check that the header used by your ISP is listed at the top. To identify which header is used by the ISP, view the properties of a message in the Administrator and look at the message headers for one displaying the correct recipients’ email address. (Repeat this for a sample of messages). You should then configure the Multi-POP3 account distribution settings, on the Advanced page of the ISP properties, to list the preferred headers that will be used for the sorting of incoming mail.

When WorkgroupMail downloads a message from the ISP it can use the selected headers to identify the correct recipient and to deliver the message to the mailbox for the correct local user. In the absence of these header fields, or if WorkgroupMail cannot find a valid email address in one of the header fields listed in the Multi-POP3 account distribution settings, the message will be delivered according to the ‘Unknown Recipients’ settings for that domain.

As a last resort it is possible to sort mail using the addresses in the To and CC header fields. However, this is not a reliable means of routing mail as the BCC recipient information will have been lost. Also, when there is more than one recipient on the local domain the message may be received many times, usually once per recipient. The best solution will be to approach the ISP to enquire if a specific header field could be used (or added) to indicate the email address of the true recipient.

More Info

Refer also to the following FAQ’s:-

After upgrading to v7, Workgroupmail stopped sorting incoming mail and now delivers it to the default user.

Workgroupmail downloads our e-mail from the ISP but the messages disappear.

I receive mail via POP3 and incoming mail is not being delivered correctly. I have noticed that the address of the true recipient in the headers has been entered incorrectly by my ISP

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