Symptoms
Outlook 2002/2003 clients can experience problems when connecting to a WorkgroupMail v7.6 server. Outlook eventually times out and does not retrieve emails from the WorkgroupMail POP3 server.
Cause
This problem, which was not apparent in earlier versions of WorkgroupMail v7, is due to an Outlook limitation. If Outlook receives a response to a request faster than it expects, it can miss the response. We have tested this with a variety of other mail servers and found the problem occured on some mail servers and not on others. We have resolved the problem in WorkgroupMail v7.6.1 beta 3 by waiting a specific period of time (default 50 milliseconds) before responding to a socket request.
Resolution
To correct this issue you must download and upgrade to the latest release of WorkgroupMail v7.Refer to the FAQ Can I upgrade to the latest release of WorkgroupMail and if so, how?
More Info
You can adjust the time that WorkgroupMail waits by creating the following registry setting on the WorkgroupMail computer. The Advanced key may need to be created if not present. SleepBeforeSend must be created as a DWORD value, measured in milliseconds (which defaults to 50 if the entry is not present).
HKEY_LOCAL_MACHINE/Software/Softalk/WorkgroupMail/Advanced/SleepBeforeSend